codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Subprocess Connection Error


On 10/17/2020 5:00 PM, Dan Stromberg wrote:
> Does this help?
> 
> https://stackoverflow.com/questions/29567051/python-error-idles-subprocess-didnt-make-connection-either-idle-cant-start

I believe I included every legitimate answer on stackoverflow, including 
that post, in the doc section linked below.

> On Sat, Oct 17, 2020 at 12:44 PM Dave Dungan via Python-list <
> python-list at python.org> wrote:
> 
>> Hello,
>>
>> I bought a book called Coding for Beginners to learn how to code using
>> Python. The first few exercises went fine. When I got to the page called
>> Recognizing types and did the exercise and saved it and tried to run the
>> module it comes up with a Subprocess Connection Error. It says, "IDLE's
>> subprocess didn't make connection. See the Start up failure section of the
>> IDLE doc, online at
>> https://docs.python.org/3/library/idle.html#startup-failure."; I went
>> there and it said to try uninstalling python and then reinstalling it.

It actually says, for 3.8+,

[some things to try]

Python installation issues occasionally stop IDLE: multiple versions can 
clash, or a single installation might need admin access. If one [cannot] 
undo the clash, or cannot or does not want to run as admin, it might be 
easiest to completely remove Python and start over.

[more things to try].

I should fix the type and move this down to the bottom as a last resort.


>> I did this and it did the same thing again. It also said something about it
>> is because of the antivirus software. I tried installing python on a
>> different computer and it happened at the exact same place in the exercises
>> in the book. I am far from being a computer whiz, just thought it would be
>> fun to learn some simple coding. Any help would be appreciated. One more
>> thing, the book says to save it as "types.py".

I'm glad you added that.  Naming files after stdlib modules is a bad 
idea and is covered by the the first item in the doc.

"A common cause of failure is a user-written file with the same name as 
a standard library module, such as random.py and tkinter.py. When such a 
file is located in the same directory as a file that is about to be run, 
IDLE cannot import the stdlib file. The current fix is to rename the 
user file."

types.py is a standard library file, so try a different name and see if 
this is the problem.

-- 
Terry Jan Reedy