codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Confused by python gtk, gobject, gi, etc. (Ubuntu repositories)


I am trying to move some code from Python 2, gtk 2 (I think!) to
Python 3.

I am very confused as to what Ubuntu repository packages I need to
install to provide the Python 3 modules I need.

Searching in the repositories (and descriptions) for pygobject what I
find is:-

    python-gi-dev/focal 3.36.0-1 amd64
      development headers for GObject Python bindings

    python-glade2/focal 2.24.0-0~201711230314~ubuntu18.04.1 amd64
      GTK+ bindings: Glade support

    python-gobject-2-dev/focal,focal 2.28.6-14ubuntu1 all
      development headers for the static GObject Python bindings

    python-gtk2/focal,now 2.24.0-0~201711230314~ubuntu18.04.1 amd64
    [installed]
      Python bindings for the GTK+ widget set

    python-gtk2-dbg/focal 2.24.0-0~201711230314~ubuntu18.04.1 amd64
      Python bindings for the GTK+ widget set (debug extension)

    python-gtk2-dev/focal,focal 2.24.0-0~201711230314~ubuntu18.04.1 all
      GTK+ bindings: devel files

    python-gtk2-doc/focal,focal 2.24.0-0~201711230314~ubuntu18.04.1 all
      Python bindings for the GTK+ widget set - documentation

    python-gtkspellcheck/focal,focal 3.0-0~3~ubuntu14.04.1 all
      spellchecking library written in Python for Gtk based on Enchant

    python-gtkspellcheck-doc/focal,focal 4.0.5-2 all
      Python GTK+ Spellcheck common documentation

    python3-gtkspellcheck/focal,focal 4.0.5-2 all
      Python 3 spellchecking library for GTK+ based on Enchant

    python3-hinawa-utils/focal,focal 0.2.0-1 all
      Library to control Audio and Music units on FireWire (IEEE1394)


So what do I need to install to get what I need?  Is it python3-gi?  I
think it is but I'm not at all sure!

Also, where do I find the pygi-convert.sh script?  I have python3-gi
installed but I don't have pygi-convert.sh.

-- 
Chris Green
?