[ironic] should console be renamed to seriale_console ?
Currently ironic supports only one type of console:
The current implementation also gives as assumed the
support for just one type of console, but not that long
ago a spec to also support a graphical console type 
has been accepted and we're now close to see a first patch
with basic support merged .
With the introduction of the support for the graphical console,
the need to define a new parameter called "console_type"
has been recognized.
In practice, at the moment that would mean having "console"
and "graphical" as console types, which could result in a
confusing and in the end not correct implementation.
With this message I'd like to start a discussion on the
potential impact of the possible future renaming of everything
that currently involves the serial console from "console" to
"serial_console" or equivalent.