codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[openstack-community] Octavia :; Unable to create load balancer


Just to close the loop on this, the octavia.conf file had
"project_name = admin" instead of "project_name = service" in the
[service_auth] section. This was causing the keystone errors when
Octavia was communicating with neutron.

I don't know if that is a bug in kolla-ansible or was just a local
configuration issue.

Michael

On Thu, Jul 30, 2020 at 1:39 PM Monika Samal <monika.samal at outlook.com> wrote:
>
> Hello Fabian,,
>
> http://paste.openstack.org/show/QxKv2Ai697qulp9UWTjY/
>
> Regards,
> Monika
> ________________________________
> From: Fabian Zimmermann <dev.faz at gmail.com>
> Sent: Friday, July 31, 2020 1:57 AM
> To: Monika Samal <monika.samal at outlook.com>
> Cc: Michael Johnson <johnsomor at gmail.com>; Amy Marrich <amy at demarco.com>; openstack-discuss <openstack-discuss at lists.openstack.org>; community at lists.openstack.org <community at lists.openstack.org>
> Subject: Re: [openstack-community] Octavia :; Unable to create load balancer
>
> Hi,
>
> just to debug, could you replace the auth_type password with v3password?
>
> And do a curl against your :5000 and :35357 urls and paste the output.
>
>  Fabian
>
> Monika Samal <monika.samal at outlook.com> schrieb am Do., 30. Juli 2020, 22:15:
>
> Hello Fabian,
>
> http://paste.openstack.org/show/796477/
>
> Thanks,
> Monika
> ________________________________
> From: Fabian Zimmermann <dev.faz at gmail.com>
> Sent: Friday, July 31, 2020 1:38 AM
> To: Monika Samal <monika.samal at outlook.com>
> Cc: Michael Johnson <johnsomor at gmail.com>; Amy Marrich <amy at demarco.com>; openstack-discuss <openstack-discuss at lists.openstack.org>; community at lists.openstack.org <community at lists.openstack.org>
> Subject: Re: [openstack-community] Octavia :; Unable to create load balancer
>
> The sections should be
>
> service_auth
> keystone_authtoken
>
> if i read the docs correctly. Maybe you can just paste your config (remove/change passwords) to paste.openstack.org and post the link?
>
>  Fabian