codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[all][requirements][monasca][gnocchi][kolla] ujson, not maintained for over 4 years, has compiler issues


> orjson supports CPython 3.6, 3.7, 3.8, and 3.9. It distributes wheels
> for Linux, macOS, and Windows. The manylinux1 wheel differs from PEP 513
> in requiring glibc 2.18, released 2013, or later. orjson does not
> support PyPy.
> 
> Given the above (I think we still need to support py35 at least) I'm not
> sure we can use it.  Though it is my preferred other than that...
> (faster than ujson, more updates (last release yesterday), etc)
> 


Thanks Matthew,
what's the status of Python 3.5 support? We've been dropping unit tests 
for 3.5 in Train [1].

[1] 
https://governance.openstack.org/tc/goals/selected/train/python3-updates.html

Witek