codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[FFE][requirements][mistral][amqp] Failing “docs” job due to the upper constraint conflict for amqp


Thanks Matthew,

For now we did this: https://review.opendev.org/#/c/685932/. So we just added â??kombuâ?? explicitly into our dependencies that forces to load the right version of amqp before oslo.messaging. That works. If that looks OK for you we can skip the mentioned bump.



Renat Akhmerov
@Nokia
On 2 Oct 2019, 23:35 +0700, Matthew Thode <mthode at mthode.org>, wrote:
> On 19-10-02 14:57:24, Renat Akhmerov wrote:
> > Hi,
> >
> > We have a failing â??docsâ?? ([1]) CI job that fails because it implicitly brings amqp 2.5.2 but this lib is not allowed to be higher than 2.5.1 in the upper-constraings.txt in the requirements project ([2]). We see that thereâ??s the patch [3] generated by the proposal bot that bumps the constraint to 2.5.2 for amqp (among others) but it was given -2.
> >
> > Please assist on how to address in the best way. Should we bump only amqp version in upper constraints for now?
> >
> > [1] https://zuul.opendev.org/t/openstack/build/6fe7c7d3e60b40458d2a98f3a293f412/log/job-output.txt#840
> > [2] https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L258
> > [3] https://review.opendev.org/#/c/681382
> >
>
> I'm going to be treating this as a FFE request to bump amqp from 2.5.1
> to 2.5.2.
> It looks like a bugfix only release so I'm fine with it. As long as we
> don't need to mask 2.5.1 in global-requirements (which would cause a
> re-release for openstack/oslo.messaging).
>
> https://github.com/celery/py-amqp/compare/2.5.1...2.5.2
>
> So, if you propose a constraints only bump of amqp-2.5.1 to 2.5.2 then I
> approve.
>
> --
> Matthew Thode
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20191003/61f5543e/attachment.html>