codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Discuss on Upgrade Calcite dependency to 1.18


hi :

Discuss on Upgrade Calcite dependency to 1.18, I think the following points
need to be considered first:
1. Upgrade Jackson version to 2.9.6
Because the Jackson version supported by calcite1.18.0 has been upgraded to
Jackson 2.9.6.
2. Need to upgrade flink - Jackson in the shaded version
Because many flink dependency from the flink - shaded.
3. Upgrade calcite version in flink-core
Upgrade from calcite 1.17.0 to calcite 1.18.0.
4. Suggest the calcite also packaged into shaded

https://issues.apache.org/jira/browse/FLINK-10076

thanks
qianjin