codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Camel Metrics Component v 2.23.0


Hello,

In Spring Boot 2.1.0.RELEASE the dependency has been moved to 4.x, while in 2.22.x we were still using 2.0.6.RELEASE and the depedency for metrics was correct.

We probably need to update the library in the main component..

Can you please raise a JIRA issue for this?

Maybe you can play with depedendecy exclusion in Spring Boot and explicitly declare the old dependencies for the moment.

Thanks for spotting this.

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Chair
Apache Karaf Committer
Apache Servicemix PMC Member
Email: ancosen1985@xxxxxxxxx
Twitter: @oscerd2
Github: oscerd






On Wednesday, December 5, 2018, 8:04:09 AM GMT+1, Larry Shields <larry.shields@xxxxxxxxx> wrote: 





Hello,

I've run into an issue with the Camel Metrics component in v2.23.0 which
appears to be due to the change in the io.dropwizard.metrics metrics-core
libraries from v3.x to 4.x.  When enabling Jmx support for the
MetricsRoutePolicyFactory, this causes an exception loading the JmxReporter
class.  It appears this is because the JMX support was migrated out of the
metrics-core libraries in v4.x which has a different path to the
JmxReporter class.

Has anyone solved this in v2.23 of the Component?  I've reverted back to
2.22 which appears to be working but would like to move up to v2.23 for the
new FHIR component and updated Spring version support.

Thanks,

Larry Shields