codehaus


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Deprecate legacy UI in favor of FAB RBAC


The branch has for 1.10 is different from master (v1-10-test and stable) so
there is no issue from that perspective. If there are fixes for 1.10 after
the merge that concern the old ui they can just be based against the right
branch.

B.


Op di 18 dec. 2018 13:49 schreef airflowuser
<airflowuser@xxxxxxxxxxxxxx.invalid:

> I don't think this can be merged until stopping adding fixes to 1.10.2 as
> there are some fixes for the old UI which this PR removes.
>
>
> Sent with ProtonMail Secure Email.
>
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
> On Tuesday, December 18, 2018 12:55 PM, Verdan Mahmood <
> verdan.mahmood@xxxxxxxxx> wrote:
>
> > Hi all,
> >
> > At the moment, we do have 2 versions of UI for Apache Airflow which is
> > really hard to maintain.
> > In an effort to remove the legacy UI, and make the FAB (RBAC UI) the
> > default and only UI version of Apache Airflow, I've opened a PR, with all
> > tests passing on Travis.
> >
> > PR: https://github.com/apache/incubator-airflow/pull/4339
> > Travis Build:
> > https://travis-ci.org/apache/incubator-airflow/builds/469438619
> >
> > Since it's a big change and really hard to keep it updated with the
> latest
> > master all the time, can someone please help with the reviews?
> >
> > Best,
> > Verdan Mahmood
>
>
>